Back to overview
Degraded

High Latency Affecting All Services

Nov 18 at 02:14pm EET
Affected services
Network Infrastructure

Resolved
Nov 18 at 06:34pm EET

Everything seems to be resolved, we will continue to monitor

Updated
Nov 18 at 05:04pm EET

The Cloudflare outage continues to impact our services. Although their status page indicates a resolution, we have not seen a corresponding recovery in latency. Our team is working to restore performance.

Created
Nov 18 at 02:14pm EET

We are aware that all services are currently experiencing high latency as a result of the ongoing Cloudflare outage. Our team is actively monitoring the situation and will implement improvements where possible. We will keep you updated as the situation evolves.

For live updates from Cloudflare, you can visit their status page:
https://www.cloudflarestatus.com/