Back to overview
Degraded
Network Issues due to large scale DDoS attack
Mar 14, 2026 at 8:17pm UTC
Affected services
DDoS Protection
Resolved
Mar 14, 2026 at 8:30pm UTC
We've implemented measures to better handle this attack.
Affected services
Created
Mar 14, 2026 at 8:17pm UTC
We're currently experiencing extremely large DDoS attacks which are causing issues. We're currently working on this
Affected services